1. Home
  2. Macintosh Software
  3. Moving Projects in Final Cut Pro X

Moving Projects in Final Cut Pro X

When you first create a project in Final Cut Pro X it will be saved to the local hard drive of the computer you are working on. Final Cut projects and events are stored in the Movies folder of the logged in user’s home folder. Do yourself a favor and never go in to that folder. All operations should be done from within Final Cut.

local_project_and_event

In the image above I have an event and project that I have been working on. Both are on the local hard drive. I want these to be on an external drive so i can edit them on any computer running the same or higher version of Final Cut Pro X. The first thing I do is connect an external drive. The drive can be USB, FireWire, or Thunderbolt. Flash/thumb drives and SD cards are NOT supported.

external_drive

After I connect my external drive Final Cut sees it and automatically makes it available to me in the application. Any events or projects on the drive are now displayed.

To move my project I select it in Final Cut then select File -> Move Project… If this option is not available in the File menu you either do not have a project selected or you do not have a supported hard drive connected. Final Cut will drop a sheet down asking you where to move your project. Make sure your external drive is Move Project and Referenced Events are both selected. If you move the project only your media will remain on the local hard drive and will be lost.

move_projectmove_location

Before you disconnect your external drive select Window -> Background Tasks in Final Cut. This will display the file copy progress. When the move is complete you can quit Final Cut and eject your external drive.

background_tasks

Now whenever your external drive is connected to your computer running Final Cut your projects and events will be available for edit.

moved

In the future if you create a new event and import new video for your project you will need to consolidate your files, moving the new video to your external drive. With your project selected go to File -> Consolidate Project Media… Make sure to select Move Referenced Events in the Consolidate Project Media sheet. You can view the progress of the move as you did when moving the project initially (Command + 9).

consolidate menuconsolidate_sheet

Updated on July 14, 2015

Related Articles